[  3  /  a  /  adv  /  an  /  c  /  cgl  /  ck  /  cm  /  co  /  diy  /  fa  /  fit  /  g  /  i  /  ic  /  jp  /  k  /  lit  /  m  /  mlp  /  mu  /  n  /  o  /  p  /  po  /  q  /  sci  /  sp  /  tg  /  toy  /  trv  /  tv  /  v  /  vg  /  vp  /  w  /  wg  /  wsg  /  x  ]

/g/ Technology

Warning: All the content of this page originally come from 4chan.org. This is only a partial archive made to avoid destruction. Some posts and images may be missing. All the messages below have been posted by anonymous users and we do not guarantee any truth of what they said.
For any illegal content, please contact me so that I can immediatly destroy it!

Anonymous 2016-01-24 05:42:10 No.52590210

[Missing image file: ]

Previously on: >>52581623

Intended for users of all levels, including absolute beginners.

There are four ways to try Linux, you can:

1) Install a Linux OS on a VM (Virtual Machine/VirtualBox) for "safety purposes"
2) Use the Live ISO directly without installing anything, that way, you can get a "full Linux experience".
3) Dual-boot Linux with Windows/Mac (recommended if you want to learn more about Linux)
4) Go balls deep and overwrite everything with Linux (not recommended)

Before asking, please find the answers to your questions in resources.

Please be civil, notice the "Friendly" in every Friendly Linux Thread.

Understand that much of your software from Windows will be unavailable, although maybe wine can make up for it.

Resources:
man <insert command here>
your friendly neighborhood search engine
https://www.codecademy.com/en/courses/learn-the-command-line
https://wiki.archlinux.org/
https://wiki.installgentoo.com/


>>
Anonymous 2016-01-24 05:43:00 No.52590224
What is Linux (or GNU/Linux for Stallmanists)?
https://wiki.installgentoo.com/index.php/GNU/Linux

Babby's First Linux (What distro to choose?)
https://wiki.installgentoo.com/index.php/Babbies_First_Linux

What software does /g/ recommend? (Please DON'T include the so called infographic [it's reddit-tier] -- refer all your recommended software here.)
https://wiki.installgentoo.com/index.php/List_of_recommended_GNU/Linux_software

Ricing on Linux (Make it good and functional or make it worse/puke-inducing like those at desktop threads)
https://wiki.installgentoo.com/index.php/GNU/Linux_ricing

A script designed to ease the transition from Windows to Debian
https://gitgud.io/Chocolate-Chip-Computing/DebianNewbieScript

Check out this page for any updates on the OP
https://wiki.installgentoo.com/index.php//flt/

IRC No one uses:
irc://irc.freenode.org:+7000/FriendlyLinux

>>
Anonymous 2016-01-24 05:59:42 No.52590408
>>52590383
>>52590398

>>
Anonymous 2016-01-24 06:01:39 No.52590425
install gentoo

>>
Anonymous 2016-01-24 06:02:55 No.52590434
>>52590425

>>
Anonymous 2016-01-24 06:05:06 No.52590458
This monitor is supposed to run at 1024x768 and 60Hz. It is not. I can not change it. This little bouncing box is annoying.

>>
Anonymous 2016-01-24 06:05:15 No.52590461
>>52590434
Here the real guide.

>>
Anonymous 2016-01-24 06:06:31 No.52590477
>>52590408
while "world" is often used, you should use "other" there, since that's what the commands use

like "chmod o+x" meaning "other set execute", or enable execute for other

perhaps add a footnote/postscript that says that other is also known as world, as in the phrase "world writable"

>>
Anonymous 2016-01-24 06:07:23 No.52590486
>>52590477
Good idea, thx!

>>
Anonymous 2016-01-24 06:13:32 No.52590560
>>52590461
Is this legit?
Anyone got a real Gentoo by following this guide?
Is it up to date?
Does it kill the Gentoo is hard meme?

>>
Anonymous 2016-01-24 06:16:19 No.52590595
Anyone in here who can tell me what is the BEST linux? Please no bully.

>>
Anonymous 2016-01-24 06:18:20 No.52590624
>>52590458
output of xrandr?

>>
Anonymous 2016-01-24 06:20:43 No.52590651
>>52590624

>>
Anonymous 2016-01-24 06:23:38 No.52590683
>>52590651
are you in a VM?

>>
Anonymous 2016-01-24 06:24:26 No.52590689
>>52590683
Nope.

>>
Anonymous 2016-01-24 06:25:36 No.52590698
>>52590689
glxinfo | grep string\:
?

>>
Anonymous 2016-01-24 06:27:18 No.52590716
>>52590698

>>
Anonymous 2016-01-24 06:31:44 No.52590740
anyone know how i can display what song is playing through spotify with i3blocks?

>>
Anonymous 2016-01-24 06:32:04 No.52590745
>>52590716
what graphics card?
lspci | grep VGA

>>
Anonymous 2016-01-24 06:34:00 No.52590770
>>52590745

>>
Anonymous 2016-01-24 06:36:57 No.52590798
>>52590770
is that an old server box?

>>
Anonymous 2016-01-24 06:38:39 No.52590818
>>52590798
Yeah, Supermicro PDSMI+ and a Pentium D. Gonna throw a Q6600 in it soon.

>>
Anonymous 2016-01-24 06:42:53 No.52590857
>>52590818
if you tried to install the amd proprietary driver, uninstall it, that card is too old for it

then make sure xserver-xorg-video-ati is installed, the free driver still supports that card

then reboot (technically not required, but less instructions to follow)

>>
Anonymous 2016-01-24 06:46:30 No.52590899
>>52590740
N E 1?

>>
Anonymous 2016-01-24 06:47:16 No.52590905
>>52590857
>>52590818
fyi it's an RV100 chip, basically an ATi Radeon 7000

>>
Anonymous 2016-01-24 06:48:53 No.52590921
>>52590905
(not to be confused with HD7000)

>>
Anonymous 2016-01-24 06:54:13 No.52590978
>>52590857
No more bouncing box, thanks m8.

>>
Anonymous 2016-01-24 06:56:29 No.52591005
>>52590978
you're welcome

>>
Anonymous 2016-01-24 07:03:33 No.52591074
Moving onto a new NAS Server. Coming from ZFS and kinda lost.

I don't understand this LVM vs RAID thing. Is there a way to install RAID before LVM? Some people seem to be doing it and getting flamed for it.

Also, any major difference in what to expect would be nice. Apparently I need to scrub more often.

>>
Anonymous 2016-01-24 07:09:12 No.52591116
you put LVM ontop of MDADM if that's what you're asking
you can use ZFS on linux as well, if you'd prefer

LVM isn't required for RAID

mdadm = linux software raid
lvm = logical volume manager (unrelated/independant of raid)
zfs = covers both functionalities (datasets work like lvm logical volumes)

>>
Anonymous 2016-01-24 07:15:26 No.52591175
>>52591116
well that makes a fuck of a lot more sense. Everything I have been reading has been a cluster of shit arguments and partial information.

Appreciate it thanks.

>>
Anonymous 2016-01-24 07:20:43 No.52591230
Any non tiling keyboard driven DE? Long story short apparently MATLAB can have issues on i3, so want something alongside it that doesnt make me want to kill myself

>>
Anonymous 2016-01-24 07:31:10 No.52591317
>>52591230
pretty much every DE has keyboard shortcuts. try xfce

>>
Anonymous 2016-01-24 07:32:04 No.52591324
>>52591175
mm, all of those projects have a lot of functionality, and in the case of mdadm and lvm, can be used together in several different ways

you can technically raid with lvm, but it's only spanned volumes (not redundant, so it's very technically a jbod)

you can think of lvm as like a "filesystem of partitions" (again, think datasets, just not exactly the same)

if you don't need lvm, you can forego it and just use the single device mdadm creates to put regular partitions on, or format it directly (mdadm makes an /dev/md? device as the raid, which you use the same as you would /dev/sd?)

>>
Anonymous 2016-01-24 07:45:43 No.52591438
>>52591074
>Apparently I need to scrub more often.
didn't respond to this, yea, you should

ZFS verifies checksums on reads, which means things you read often are scrubbed often naturally

mdadm doesn't do this, only a manually-invoked scrub can check for inconsistencies (and obviously, you need a raid level with parity to fix any errors along the way, like raid5/6)

usual practice is to use a cron job or similar to peridically trigger a scrub operation

>>
Anonymous 2016-01-24 07:49:32 No.52591469
>>52590560
>>52590560
just read the gentoo handbook from the actual gentoo wiki, its no harder than installing arch, it takes a while to get used to maintaining gentoo compared to arch tho imo

>>
Anonymous 2016-01-24 08:36:03 No.52591839
> all systemctl commands return
failed to get bus connection

Why is this?

>>
Anonymous 2016-01-24 08:37:17 No.52591850
Why is Nvidia such a piece of shit. So I installed Arch on my main PC finally, using it happily on my laptop.

Anyway here's the situation. Before installing nvidia drivers, all 3 monitors are working - mirrored - in the TTY before I login which is set to kick off X. After installing the nvidia drivers all the monitors went dead after booting. Great. Anyway, after some research I figured out I had to edit grub with 'nomodeset' inside GRUB_CMDLINE_LINUX_DEFAULT. So I do that and reboot and tada, now a single monitor is working in the TTY. Well I guess I can live with that, it's really annoying because it's my worst and smallest monitor and I generally have it turned off so if someone knows how to fix this please tell me.

Finally I boot into i3 -and fix positioning etc with xrandr- where I encounter a small but irritating problem. It seems my monitors identify incorrectly, while I would call them monitors 1 2 and 3, they call themselves 3 2 and 1. This fucks up the start workspaces putting 3 on monitor #1 etc. Now again, I CAN work around this, reorder my config to suit etc. But this is kind of dumb and annoying and there MUST be a way to simply tell the system which monitor is which. Possibly connected to the original issue where monitors 1 and 2 -or 3 and 2 according to linux- don't work in the TTY.

Send help senpai.

>>
Anonymous 2016-01-24 08:37:34 No.52591852
>>52590434
So what does this actually do to your computer?

Glad to see a spin on the old system32 meme.

>>
Anonymous 2016-01-24 08:47:03 No.52591928
>>52591852
It's basically sudo rm -rf / in DOS.

>>
Anonymous 2016-01-24 09:01:52 No.52592040
>>52591852

>>
Anonymous 2016-01-24 09:03:18 No.52592057
>>52592040

>>
Anonymous 2016-01-24 09:05:28 No.52592082
>>52592057
>Embrace system32
MY SIDES

>>
Anonymous 2016-01-24 09:11:15 No.52592130
>>52592057
Can someone point me to where I can find an archive of this tumblr post. Wayback machine doesn't have it.

>>
Anonymous 2016-01-24 09:11:15 No.52592131
Assuming my wine environment got compromised by a windows virus.
How do I clean it up?

>>
Anonymous 2016-01-24 09:12:50 No.52592147
>>52592131
ClamAV might work

>>
Anonymous 2016-01-24 09:16:01 No.52592174
>>52592147
Won't deleting the Wine environment solve it?

>>
Anonymous 2016-01-24 09:17:18 No.52592182
>>52592174
>>52592131
WINE can't get viruses. It works differently from your regular MS system.

>>
Anonymous 2016-01-24 09:18:15 No.52592192
>>52592174
I am assuming you want to preserve the environment

>>
Anonymous 2016-01-24 09:18:30 No.52592197
>>52590425
>Has had the best wiki in the business
>Server crashes
>Autists kept no backups
Give me one good reason to trust those incompetent devs

>>
Anonymous 2016-01-24 09:18:41 No.52592198
What exactly do you give up by going with an ultra minimal distro like Tiny Core? Will normal software even run on it?

>>
Anonymous 2016-01-24 09:19:36 No.52592209
>>52590595
Linux-libre

>>
Anonymous 2016-01-24 09:20:33 No.52592218
>>52592182
Yes it can.
>>52592192
If possible, yes.
I was thinking of deleting .wine folder will it do?
And if using PlayOnLinux makes a difference.

>>
Anonymous 2016-01-24 09:21:43 No.52592231
>>52592182
https://wiki.winehq.org/FAQ
>Just because Wine runs on a non-Windows OS doesn't mean you're protected from viruses, trojans, and other forms of malware.

>>
Anonymous 2016-01-24 09:26:34 No.52592283
>>52591850
Anyone? Surely this isn't too rare of an issue.

>>
Anonymous 2016-01-24 09:29:41 No.52592325
So I spent days trying to get Debian to Samba share a NTFS external drive over my network to Win7/Android clients. I tried everything every which way: I edited fstab to get the drive mounted so permissions could be edited, I had nobody own the drive, I have the smb.conf edited to anonymously share the drive--nothing worked. The closest I could get was the share folder could be seen but never accessed: either credentials were asked for or Windows said it couldn't find the network location.

While googling the umpteenth different facet of the problem on the third day, I saw an offhanded reference to caja-share (my Debian install has MATE and Caja). I read what little there is on it, saw it's supposed to Samba share folders Windows-style (right-click, Share, boom, done), apt-get install, ... it just werks.

>mindblown.gif

The only trouble is, I haven't learned what sorcery it used to make what I'd been flailing around with work. It didn't add anything to smb.conf anywhere that I can see. As much as I appreciate it making the share work, I'd like to know how so I could at least (incorrectly) justify wasting another 3 days with loonix doing what takes moments in Windows. Any ideas where to look?

>>
Anonymous 2016-01-24 09:33:06 No.52592359
>>52592325
It's the samba.conf.
I'm on manjaro, tried to make the share work for a week, but nothing worked.
Finally I installed thunare-share-plugin, and copied the samba.conf for it.
Everything worked beautifully.

>>
Anonymous 2016-01-24 09:33:25 No.52592365
>>52592231
Well, this is directed to WINE's virtual C:\ directory and programs running in WINE. A virus, made to delete shit, or a worm, made to copy itself etc wount be able to do anything outside of C:\.

>>
Anonymous 2016-01-24 09:34:56 No.52592381
hello, I'm trying to fix a pkgbuild and this SED command is broken with a 'unknown option to s'

I've checked the man but I can't get my head around what's wrong here, my googling is consistently telling me something about slashes and quotes but I can't figure this out

send help

SCRIPT=$(echo "s=SHLIBDIR = /usr/X11R6/lib=SHLIBDIR = ${startdir}/pkg/usr/X11R6/lib=;s=LIBDIR = /usr/X11R6/lib/X11=LIBDIR = ${startdir}/pkg/usr/X11R6/lib/X11=;s=XTOP = $(TOP)=XTOP = /usr/X11R6=;s=ETCX11DIR = /etc/X11=ETCX11DIR = ${startdir}/pkg/etc/X11=;s=BINDIR = /usr/X11R6/bin=BINDIR = ${startdir}/pkg/usr/X11R6/bin=;s=$${RELPATH}=/usr/X11R6/lib/X11=")
sed -e "$SCRIPT" < Makefile > Makefile.tmp

>>
Anonymous 2016-01-24 09:36:13 No.52592392
>>52592365
There is also the SMALL possibility that the virus could affect Linux as well.
Refer to my link in the post you quoted
>Wine does not sandbox in any way at all. When run under Wine, a Windows app can do anything your user can. Wine does not (and cannot) stop a Windows app directly making native syscalls, messing with your files, altering your startup scripts, or doing other nasty things.

>>
Anonymous 2016-01-24 09:38:43 No.52592417
>>52592392
Ok you're right here, but to be honest, who writes linux malware and cross compiles it as windows binary...

>>
Anonymous 2016-01-24 09:39:37 No.52592424
>>52592365
So having PoL is better than having WINE only since you have a separate wineprefix for each application, and simply deleting it will remove the malware.

>>
Anonymous 2016-01-24 09:39:42 No.52592426
>>52592417
That's why SMALL is in all caps. The possibility is there. It's not a big one by any means, but it's there.

>>
Neckbeard 2016-01-24 09:41:31 No.52592444
>>52592417
A really bored autist.

>>
Anonymous 2016-01-24 09:41:50 No.52592449
>>52592424
- Protect WINE with Common Sense 2016.
- Run unknown Windows shit in a sandbox.

>>
Anonymous 2016-01-24 09:43:46 No.52592466
>>52592449
What's a good and simple sandbox for Lunix?

>>
Anonymous 2016-01-24 09:44:43 No.52592475
>>52592359

caja-share doesn't appear to edit smb.conf. Trying to find more information on caja-share is like trying to get the Smoking Man to tell you where the aliens are.

Really, I just want to know how it got this to work. I had to screw with Samba, fstab, chown, iptables, Win7 networking, registry, Group Policy objects, and I simply do not understand how this thing managed to make this work.

>>
Anonymous 2016-01-24 09:44:51 No.52592477
Any compton experts around here?
>inb4 compton --backend glx --paint-on-overlay --vsync opengl-swc
whoever keeps parroting this should fuck off

so my exact currently flags are
compton -CGb --backend glx --paint-on-overlay --vsync opengl-swc

basically some existing ones I had from who knows when, possibly the crunchbang default or something + the meme flags

current situation:
>I still tearing (is it even possible to not? what the fuck)
>there's no always display lag with video playback whether it's from youtube, vlc, or mpv

The new lag combined with the tearing has lead people who normally watch anime over here to complain. I had already gotten complaints of tearing in the past and tried my best to fix it, but now the lag has made people tell me to just not bother until it's fixed. What do?

>>
Anonymous 2016-01-24 09:47:40 No.52592506
>>52592477
--backend glx usually fixes any problems, never had problems here, but two things: is it possible that you're running another compositor next to compton? if graphic card, have you played with it's settings?

>>
Anonymous 2016-01-24 09:50:27 No.52592532
>>52592477
>>52592506
okay so I realized I left out important info, mostly that I'm using an nvidia gpu

sounds like vsync in nvidia-settings can conflict with compton vsync and cause more tearing

question for you, my friend, do you actually know what these flags do? should I remove some of the ones I'm using?

>>
Anonymous 2016-01-24 09:51:01 No.52592540
>>52592477
Add --config /dev/null.
Maybe you have a compton.conf somewhere that overwrites your cmd settings -
Just an idea.

>>
Anonymous 2016-01-24 09:51:34 No.52592550
>>52505453
I created a script trackpoint.sh in /usr/bin

echo 120 | sudo tee /sys/devices/platform/i8042/serio1/speed
echo 250 | sudo tee /sys/devices/platform/i8042/serio1/sensitivity


and a service trackpoint.service in /etc/systemd/system

[Unit]
Description=Increase trackpoint sensitivity

[Service]
ExecStart=/usr/bin/trackpoint.sh

[Install]
WantedBy=multi-user.target %


and finally ran the following commands
$ sudo chmod 755 /usr/bin/trackpoint.sh
$ sudo systemctl enable trackpoint.service


When I restarted my computer, nothing changed.

>>
Anonymous 2016-01-24 09:51:38 No.52592552
>>52592475
But that's the only possible explanation.

>>
Anonymous 2016-01-24 09:52:18 No.52592563
>>52592540
it seems I do have a compton.conf inside my .config folder

should I be making edits there instead of to my i3 config where it autostarts?

>>
Anonymous 2016-01-24 09:52:33 No.52592566
>>52592532
Have you read compton -h?
All answers there.

>>
Anonymous 2016-01-24 09:53:21 No.52592570
>>52592477
compton --backend glx --paint-on-overlay --vsync opengl-swc -f
never failed me, do you have another one running?
to know what they do just RTFM.







[  3  /  a  /  adv  /  an  /  c  /  cgl  /  ck  /  cm  /  co  /  diy  /  fa  /  fit  /  g  /  i  /  ic  /  jp  /  k  /  lit  /  m  /  mlp  /  mu  /  n  /  o  /  p  /  po  /  q  /  sci  /  sp  /  tg  /  toy  /  trv  /  tv  /  v  /  vg  /  vp  /  w  /  wg  /  wsg  /  x  ]

Contact me | All the content on this website come from 4chan.org. All trademarks and copyrights on this page are owned by their respective parties. Images uploaded are the responsibility of the Poster. Comments are owned by the Poster.

Dofus quêtes

Page loaded in 0.031135 seconds.